System Requirements for SQL Server

Updated

Verify that your environment meets the system requirements for SQL Server.

Application

  • Microsoft SQL Server 2019 Editions up to the latest Service Pack

  • Microsoft SQL Server 2017 Editions up to the latest Service Pack

  • Microsoft SQL Server 2016 Editions up to the latest Service Pack

  • Microsoft SQL Server 2014 Editions up to the latest Service Pack

  • Microsoft SQL Server 2012 Editions up to the latest Service Pack

  • Microsoft SQL Server 2008 R2 Editions up to the latest Service Pack

  • Microsoft SQL Server 2008 Editions up to the latest Service Pack

  • Microsoft SQL Server 2005 Editions up to the latest Service Pack

Operating System

Windows

Operating system

Processor architecture

Microsoft Windows Server 2019 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2016 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2012 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2012 R2 Editions

All Windows-compatible processors are supported

Microsoft Windows 10

All Windows-compatible processors are supported

Microsoft Windows 8 Editions

All Windows-compatible processors are supported

Microsoft Windows 7 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2008 Editions with a minimum of Service Pack 1

All Windows-compatible processors are supported

Microsoft Windows Server 2008 R2 Editions

All Windows-compatible processors are supported

Microsoft Windows Vista Editions

Use the Metallic user account (and not the local system account) to run the Metallic Communications Service (GxCVD).

All Windows-compatible processors are supported

Software That Is Automatically Installed

Microsoft Visual C++ Redistributable 2017

Starting with Service Pack 18, Microsoft Visual C++ Redistributable 2017 (vcredist2017.exe) is automatically installed.

If a computer does not have the most recent Windows updates, the installation of Microsoft Visual C++ Redistributable 2017 will fail in installing Universal C Runtime. The following Windows updates must be installed to prevent the installation failure. The updates are not required on the most recent Windows operating system versions, such as Microsoft Windows 10 and Microsoft Windows Server 2016, because these versions have the Universal C Runtime already installed.

  • KB2919355

  • KB2939087

  • KB2975061

  • KB2999226

.NET Framework

  • On most versions of Windows, the .NET Framework 4.6.2 is automatically installed.

  • On Windows 2008 and Windows Vista, .NET Framework 4.0 is required.

    Note: Beginning with Feature Release 11.27, .NET Framework 4.0 is not packaged with Metallic custom media. Therefore, if a Windows 2008 or Windows Vista computer requires an installation of .NET Framework 4.0, note the following:

    • If the computer has an Internet connection, the installer will download .NET Framework 4.0 from the Internet and then install it on the computer.

If the computer does not have an Internet connection, you must manually install .NET Framework 4.0 on the computer, and then install Metallic on the computer.

Java SE Platform

The Java version is installed automatically during the installation of this software. If you already have a system installed Java version, the software will install another instance of the supported Java version in the software installation path.

Manually upgrading the Java version installed by the software is not supported.

DISCLAIMER

Certain third-party software and service releases (together, "Releases") may not be supported by Commvault. You are solely responsible for ensuring Commvault’s products and services are compatible with any such Releases.